Το forum δεν στέλνει mails

Υποστήριξη σχετικά με οποιοδήποτε θέμα του phpBB (σειρά εκδόσεων 3.2.x).
Σημείωση: Εδώ μπορείτε να αναζητάτε βοήθεια για τη λειτουργία του phpBB μόνο.
Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 301
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Τρί 13 Αύγ 2019, 17:11

Καλησπέρα.

Διαπίστωσα ότι το forum δεν στέλνει mails γενικώς (εγγραφές, ειδοποιήσεις).
Επειδή το παρατήρησα όταν έκανα αναβάθμιση σε 3.2.7 (πιθανό το πρόβλημα να προϋπήρχε) έκανα αναζήτηση στο phpbb.com και βρήκα ότι ενδεχομένως για το πρόβλημα να ευθύνεται ο server (ρυθμίσεις του ηλεκτρονικού ταχυδρομείου).

Από τις "Ρυθμίσεις Ηλεκτρονικού Ταχυδρομείου" του ΠΕΔ, κάνοντας "Αποστολή δοκιμαστικού μηνύματος", παίρνω το παρακάτω:
Το δοκιμαστικό μήνυμα ηλεκτρονικού ταχυδρομείου στάλθηκε.
Αν δεν το λάβατε, παρακαλούμε ελέγξτε τις ρυθμίσεις του ηλεκτρονικού ταχυδρομείου.
Να σημειώσω ότι στο Ιστορικό Σφαλμάτων δεν καταγράφεται κάτι σχετικό.

Τι να κοιτάξω;
Οποιαδήποτε άλλη πληροφορία είναι διαθέσιμη.

Άβαταρ μέλους
tzampatzis
Διαχειριστής
Διαχειριστής
Δημοσιεύσεις: 255
Εγγραφή: Τρί 26 Ιαν 2016, 09:02
Τοποθεσία: Παναγιώτης@Λέσβος
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από tzampatzis » Τρί 13 Αύγ 2019, 20:03

Το phpbb προεπιλεγμένα χρησιμοποιεί την συνάρτηση mail() της PHP για να στείλει τα μηνύματα.
Πολλοί provider απενεργοποιούν αυτή τη δυνατότητα, ή οι ρυθμίσεις που κάνουν δεν είναι απόλυτα συμβατές με τον τρόπο που χειρίζεται τα mail το phpbb. Μπορείς είτε να χρησιμοποιήσεις κάποιο SMTP (π.χ. Gmail) ή να δοκιμάσεις να γυρίσεις τη ρύθμιση SMTP σε ναι και στο server να βάλεις localhost και port την 25 με τα υπόλοιπα κενά.

Είναι περίεργο που δεν εμφανίζει κάποιο σφάλμα όμως. Μήπως πάνε τα mail στα spam ή αργούν;
Δεν παρέχεται υποστήριξη μέσω προσωπικών μηνυμάτων, γι' αυτό έχουμε το phpBBgr.com

Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 301
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Τρί 13 Αύγ 2019, 22:06

tzampatzis έγραψε:
Τρί 13 Αύγ 2019, 20:03
Μήπως πάνε τα mail στα spam ή αργούν;
Στα spam όχι, για να καθυστερούν δεν το έχω παρατηρήσει.
tzampatzis έγραψε:
Τρί 13 Αύγ 2019, 20:03
Είναι περίεργο που δεν εμφανίζει κάποιο σφάλμα όμως.
Εμφανίζει άλλο άσχετο πρόβλημα για το οποίο θα ανοίξω άλλο θέμα μιας και ...κάποια στιγμή πρέπει να λυθεί κι αυτό.

Ξέχασα να αναφέρω ότι η έκδοση php είναι 5.6.40 η οποία είναι "outdated". Δεν ξέρω αν αυτό έχει κάποια σχέση.
Η επόμενη έκδοση php που μου δίνει ο server είναι 7.χ και πρέπει να ρωτήσω τον server μιας και παράλληλα έχω και κάποιο site και δεν ξέρω αν υποστηρίζεται.

Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 301
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Πέμ 29 Αύγ 2019, 12:47

Καλημέρα.

Επανέρχομαι μιας και το πρόβλημα παραμένει.
tzampatzis έγραψε:
Τρί 13 Αύγ 2019, 20:03
να δοκιμάσεις να γυρίσεις τη ρύθμιση SMTP σε ναι και στο server να βάλεις localhost και port την 25 με τα υπόλοιπα κενά
Δυστυχώς, τίποτα.

Επίσης, μίλησα με το hosting και μου έδωσε κάποια στοιχεία χωρίς και πάλι αποτέλεσμα.
forum_email.png
Το επόμενο που σκέφτομαι είναι να στήσω ένα δοκιμαστικό forum για να δω τι θα κάνει, εκτός αν υπάρχει κάτι άλλο να κάνω.

Edit
Το "Όνομα χρήστη SMTP" το άλλαξα σε mail.4gps.gr που προφανώς είναι το σωστό αλλά και πάλι δεν λειτουργεί.
Δεν έχετε τα απαραίτητα δικαιώματα για να δείτε τα συνημμένα αρχεία σε αυτή τη δημοσίευση.

Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 301
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Παρ 30 Αύγ 2019, 22:54

Καλησπέρα.

Έστησα το δοκιμαστικό forum (testforum.4gps.gr) και σε "Αποστολή δοκιμαστικού μηνύματος" το μήνυμα στάλθηκε.
Τις ρυθμίσεις ηλεκτρονικού ταχυδρομείου τις άφησα όπως ήταν από προεπιλογή.
Έβαλα τις ίδιες ρυθμίσεις στο κανονικό forum αλλά αυτό επιμένει να μην στέλνει μηνύματα.
Το email είναι το ίδιο και στα δυο forums.

Θα αρχίσω να ανεβάζω τις επεκτάσεις αλλά μήπως υπάρχει και κάτι άλλο να κοιτάξω;

Άβαταρ μέλους
greko11
Συντονιστής
Συντονιστής
Δημοσιεύσεις: 321
Εγγραφή: Παρ 25 Μαρ 2016, 19:35
Τοποθεσία: Γρηγόρης@ Θεσ/νίκη
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από greko11 » Σάβ 31 Αύγ 2019, 12:44

gtsoukn έγραψε:
Παρ 30 Αύγ 2019, 22:54
Θα αρχίσω να ανεβάζω τις επεκτάσεις αλλά μήπως υπάρχει και κάτι άλλο να κοιτάξω;
Καλησπέρα
Όπως σου είπα και στο πμ από κάποια επεκτάσει πρέπει να στο κάνει.
Δες το πμ πια να κοιτάξεις πρώτα.
Δεν παρέχεται υποστήριξη μέσω προσωπικών μηνυμάτων, γι' αυτό υπάρχει το φόρουμ.
Με το δικό σας πρόβλημα αν υπάρχει στο φόρουμ μπορεί να βοηθήσει και κάποιο άλλο μέλος.

Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 301
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Τρί 17 Σεπ 2019, 15:16

Καλησπέρα.

Να επαναφέρω το θέμα μιας και το είχα εγκαταλείψει λόγω άλλων προτεραιοτήτων.
Το πρόβλημα παραμένει ...εν μέρει.

Αρχικά, από τον έλεγχο των επεκτάσεων δεν προέκυψε κάτι.

Για την ιστορία, από την δημιουργία του forum, εγώ ως μέλος-διαχειριστής είχα δηλώσει το προσωπικό μου email ενώ ως email του forum είχα ορίσει το admin@4gps.gr το οποίο δεν αντιστοιχούσε σε κάποιο μέλος χωρίς να έχω κάποιο εμφανές πρόβλημα.

Μετά την εμφάνιση του προβλήματος και μετά από δοκιμές σε δοκιμαστικό forum κατέληξα στη δημιουργία ενός μέλους-διαχειριστή (4GPS) με email αυτό του forum.
Με αυτό τον τρόπο λύθηκε το πρόβλημα αποστολής email από πλευράς του διαχειριστή, δηλ. στέλνονται emails για εγγραφές νέων μελών και από την "Επικοινωνία με τον διαχειριστή". Επίσης στέλνονται emails-ειδοποιήσεις για νέα θέματα και δημοσιεύσεις όταν αυτά γίνονται από το μέλος 4GPS.
Δεν στέλνονται όμως ειδοποιήσεις όταν γίνονται δημοσιεύσεις από οποιοδήποτε άλλο μέλος.
Επίσης, με την παραπάνω αλλαγή ξεκίνησε και η καταγραφή σφαλμάτων όσο αφορά τα μη απεσταλμένα emails.
Ενδεικτικά:
Spoiler:
Μέλος: gtsoukn
Ημ/νία: Τετ 28 Αύγ 2019, 10:01 pm

Κώδικας: Επιλογή όλων

Σφάλμα ηλεκτρονικού ταχυδρομείου
» EMAIL/SMTP
/adm/index.php

Δεν ήταν δυνατόν να ληφθούν οι κώδικες απόκρισης του διακομιστή ηλεκτρονικού ταχυδρομείου.
Backtrace

Connecting to linux48.***.gr:465
Spoiler:
Μέλος: ni***
Ημ/νία: Παρ 30 Αύγ 2019, 9:44 am

Κώδικας: Επιλογή όλων

Σφάλμα ηλεκτρονικού ταχυδρομείου
» EMAIL/SMTP
/cron.php

Could not get mail server response codes.
Backtrace

Connecting to linux48.***.gr:465
Spoiler:
Μέλος: gtsoukn
Ημ/νία: Σάβ 07 Σεπ 2019, 1:34 pm

Κώδικας: Επιλογή όλων

Σφάλμα ηλεκτρονικού ταχυδρομείου
» EMAIL/SMTP
/adm/index.php

Υπάρχει πρόβλημα κατά την αποστολή ηλεκτρονικού ταχυδρομείου στην Γραμμή 1241. Απόκριση: 454 4.7.1 : Relay access denied
.
Backtrace

Connecting to localhost:25
LINE: 1205 <- 220 server.linux44.***.gr ESMTP Postfix

# EHLO server.linux44.***.gr
LINE: 1552 <- 250-server.linux44.***.gr

LINE: 1552 <- 250-PIPELINING

LINE: 1552 <- 250-SIZE 41943040

LINE: 1552 <- 250-ETRN

LINE: 1552 <- 250-STARTTLS

LINE: 1552 <- 250-AUTH CRAM-MD5 PLAIN LOGIN

LINE: 1552 <- 250-XFORWARD NAME ADDR PROTO HELO SOURCE PORT IDENT

LINE: 1552 <- 250-ENHANCEDSTATUSCODES

LINE: 1552 <- 250-8BITMIME

LINE: 1552 <- 250 DSN

# STARTTLS
LINE: 1597 <- 220 2.0.0 Ready to start TLS

# EHLO server.linux44.***.gr
LINE: 1552 <- 250-server.linux44.***.gr

LINE: 1552 <- 250-PIPELINING

LINE: 1552 <- 250-SIZE 41943040

LINE: 1552 <- 250-ETRN

LINE: 1552 <- 250-AUTH CRAM-MD5 PLAIN LOGIN

LINE: 1552 <- 250-XFORWARD NAME ADDR PROTO HELO SOURCE PORT IDENT

LINE: 1552 <- 250-ENHANCEDSTATUSCODES

LINE: 1552 <- 250-8BITMIME

LINE: 1552 <- 250 DSN

# MAIL FROM:<admin@4gps.gr>
LINE: 1221 <- 250 2.1.0 Ok

# RCPT TO:<gts***@gmail.com>
LINE: 1241 <- 454 4.7.1 <gts***@gmail.com>: Relay access denied 
Spoiler:
Μέλος: ni***
Ημ/νία: Παρ 13 Σεπ 2019, 5:53 pm

Κώδικας: Επιλογή όλων

Σφάλμα ηλεκτρονικού ταχυδρομείου
» EMAIL/SMTP
/cron.php

Ran into problems sending email at Line 1241. Response: 454 4.7.1 : Relay access denied
.
Backtrace

Connecting to localhost:25
LINE: 1205 <- 220 server.linux44.***.gr ESMTP Postfix

# EHLO server.linux44.***.gr
LINE: 1552 <- 250-server.linux44.***.gr

LINE: 1552 <- 250-PIPELINING

LINE: 1552 <- 250-SIZE 41943040

LINE: 1552 <- 250-ETRN

LINE: 1552 <- 250-STARTTLS

LINE: 1552 <- 250-AUTH CRAM-MD5 PLAIN LOGIN

LINE: 1552 <- 250-XFORWARD NAME ADDR PROTO HELO SOURCE PORT IDENT

LINE: 1552 <- 250-ENHANCEDSTATUSCODES

LINE: 1552 <- 250-8BITMIME

LINE: 1552 <- 250 DSN

# STARTTLS
LINE: 1597 <- 220 2.0.0 Ready to start TLS

# EHLO server.linux44.***.gr
LINE: 1552 <- 250-server.linux44.***.gr

LINE: 1552 <- 250-PIPELINING

LINE: 1552 <- 250-SIZE 41943040

LINE: 1552 <- 250-ETRN

LINE: 1552 <- 250-AUTH CRAM-MD5 PLAIN LOGIN

LINE: 1552 <- 250-XFORWARD NAME ADDR PROTO HELO SOURCE PORT IDENT

LINE: 1552 <- 250-ENHANCEDSTATUSCODES

LINE: 1552 <- 250-8BITMIME

LINE: 1552 <- 250 DSN

# MAIL FROM:<admin@4gps.gr>
LINE: 1221 <- 250 2.1.0 Ok

# RCPT TO:<gts***@gmail.com>
LINE: 1241 <- 454 4.7.1 <gts***@gmail.com>: Relay access denied 
Spoiler:
Μέλος: Anonymous
Ημ/νία: Δευ 16 Σεπ 2019, 4:57 pm

Κώδικας: Επιλογή όλων

Σφάλμα ηλεκτρονικού ταχυδρομείου
» EMAIL/SMTP
/ucp.php

Υπάρχει πρόβλημα κατά την αποστολή ηλεκτρονικού ταχυδρομείου στην Γραμμή 1241. Απόκριση: 454 4.7.1 : Relay access denied
.
Backtrace

Connecting to localhost:25
LINE: 1205 <- 220 server.linux44.***.gr ESMTP Postfix

# EHLO server.linux44.***.gr
LINE: 1552 <- 250-server.linux44.***.gr

LINE: 1552 <- 250-PIPELINING

LINE: 1552 <- 250-SIZE 41943040

LINE: 1552 <- 250-ETRN

LINE: 1552 <- 250-STARTTLS

LINE: 1552 <- 250-AUTH CRAM-MD5 PLAIN LOGIN

LINE: 1552 <- 250-XFORWARD NAME ADDR PROTO HELO SOURCE PORT IDENT

LINE: 1552 <- 250-ENHANCEDSTATUSCODES

LINE: 1552 <- 250-8BITMIME

LINE: 1552 <- 250 DSN

# STARTTLS
LINE: 1597 <- 220 2.0.0 Ready to start TLS

# EHLO server.linux44.***.gr
LINE: 1552 <- 250-server.linux44.***.gr

LINE: 1552 <- 250-PIPELINING

LINE: 1552 <- 250-SIZE 41943040

LINE: 1552 <- 250-ETRN

LINE: 1552 <- 250-AUTH CRAM-MD5 PLAIN LOGIN

LINE: 1552 <- 250-XFORWARD NAME ADDR PROTO HELO SOURCE PORT IDENT

LINE: 1552 <- 250-ENHANCEDSTATUSCODES

LINE: 1552 <- 250-8BITMIME

LINE: 1552 <- 250 DSN

# MAIL FROM:<admin@4gps.gr>
LINE: 1221 <- 250 2.1.0 Ok

# RCPT TO:<cri***@gmail.com>
LINE: 1241 <- 454 4.7.1 <cri***@gmail.com>: Relay access denied 
Το τελευταίο ενδεχομένως να είναι τυχαίο συμβάν, αν μπορεί να χαρακτηριστεί έτσι.
Αφορά εγγραφή νέου μέλους το οποίο είναι ακόμα ανενεργό αλλά αργότερα υπήρξε νέα εγγραφή η οποία ενεργοποιήθηκε από τον χρήστη.

Να σημειώσω ότι στο διάστημα αυτό (των σφαλμάτων) έκανα αλλαγές στις ρυθμίσεις ηλεκτρονικού ταχυδρομείου και μάλλον γι' αυτό εμφανίζονται συνδέσεις στον server του παρόχου μου αρχικά και στο localhost (αν έτσι πρέπει να είναι) μετέπειτα.

Απάντηση