Το forum δεν στέλνει mails

Υποστήριξη σχετικά με οποιοδήποτε θέμα του phpBB (σειρά εκδόσεων 3.2.x).
Σημείωση: Εδώ μπορείτε να αναζητάτε βοήθεια για τη λειτουργία του phpBB μόνο.
Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 295
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Τρί 13 Αύγ 2019, 17:11

Καλησπέρα.

Διαπίστωσα ότι το forum δεν στέλνει mails γενικώς (εγγραφές, ειδοποιήσεις).
Επειδή το παρατήρησα όταν έκανα αναβάθμιση σε 3.2.7 (πιθανό το πρόβλημα να προϋπήρχε) έκανα αναζήτηση στο phpbb.com και βρήκα ότι ενδεχομένως για το πρόβλημα να ευθύνεται ο server (ρυθμίσεις του ηλεκτρονικού ταχυδρομείου).

Από τις "Ρυθμίσεις Ηλεκτρονικού Ταχυδρομείου" του ΠΕΔ, κάνοντας "Αποστολή δοκιμαστικού μηνύματος", παίρνω το παρακάτω:
Το δοκιμαστικό μήνυμα ηλεκτρονικού ταχυδρομείου στάλθηκε.
Αν δεν το λάβατε, παρακαλούμε ελέγξτε τις ρυθμίσεις του ηλεκτρονικού ταχυδρομείου.
Να σημειώσω ότι στο Ιστορικό Σφαλμάτων δεν καταγράφεται κάτι σχετικό.

Τι να κοιτάξω;
Οποιαδήποτε άλλη πληροφορία είναι διαθέσιμη.

Άβαταρ μέλους
tzampatzis
Διαχειριστής
Διαχειριστής
Δημοσιεύσεις: 247
Εγγραφή: Τρί 26 Ιαν 2016, 09:02
Τοποθεσία: Παναγιώτης@Λέσβος
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από tzampatzis » Τρί 13 Αύγ 2019, 20:03

Το phpbb προεπιλεγμένα χρησιμοποιεί την συνάρτηση mail() της PHP για να στείλει τα μηνύματα.
Πολλοί provider απενεργοποιούν αυτή τη δυνατότητα, ή οι ρυθμίσεις που κάνουν δεν είναι απόλυτα συμβατές με τον τρόπο που χειρίζεται τα mail το phpbb. Μπορείς είτε να χρησιμοποιήσεις κάποιο SMTP (π.χ. Gmail) ή να δοκιμάσεις να γυρίσεις τη ρύθμιση SMTP σε ναι και στο server να βάλεις localhost και port την 25 με τα υπόλοιπα κενά.

Είναι περίεργο που δεν εμφανίζει κάποιο σφάλμα όμως. Μήπως πάνε τα mail στα spam ή αργούν;
Δεν παρέχεται υποστήριξη μέσω προσωπικών μηνυμάτων, γι' αυτό έχουμε το phpBBgr.com

Άβαταρ μέλους
gtsoukn
Ενεργό μέλος
Ενεργό μέλος
Δημοσιεύσεις: 295
Εγγραφή: Τετ 10 Αύγ 2016, 20:04
Τοποθεσία: Γιώργος @ Πάτρα
Επικοινωνία:

Re: Το forum δεν στέλνει mails

Δημοσίευση από gtsoukn » Τρί 13 Αύγ 2019, 22:06

tzampatzis έγραψε:
Τρί 13 Αύγ 2019, 20:03
Μήπως πάνε τα mail στα spam ή αργούν;
Στα spam όχι, για να καθυστερούν δεν το έχω παρατηρήσει.
tzampatzis έγραψε:
Τρί 13 Αύγ 2019, 20:03
Είναι περίεργο που δεν εμφανίζει κάποιο σφάλμα όμως.
Εμφανίζει άλλο άσχετο πρόβλημα για το οποίο θα ανοίξω άλλο θέμα μιας και ...κάποια στιγμή πρέπει να λυθεί κι αυτό.

Ξέχασα να αναφέρω ότι η έκδοση php είναι 5.6.40 η οποία είναι "outdated". Δεν ξέρω αν αυτό έχει κάποια σχέση.
Η επόμενη έκδοση php που μου δίνει ο server είναι 7.χ και πρέπει να ρωτήσω τον server μιας και παράλληλα έχω και κάποιο site και δεν ξέρω αν υποστηρίζεται.

Απάντηση